ZenPack:Predictive Threshold (Community)

From Zenoss Wiki
This is the approved revision of this page; it is not the most recent. View the most recent revision.
Jump to: navigation, search
Author(s)
Eric Edgar
Current Maintainer(s)
Jane Curry
Organization
Skills 1st
License
GNU General Public License, Version 2, or later
ZenPack name
ZenPacks.community.PredictiveThreshold
More Information
GitHub page/HomePage
Link to more docs
View Documentation
Git sources (for cloning)
Link




Predictive Threshold (Community) ZenPack

This ZenPack adds a new Predictive Threshold type for determining when to trigger an event.

Warning

The ZenPack Catalog has moved to its new home at https://www.zenoss.com/product/zenpacks as of January 17, 2017. The following information may be out of date, and this page will eventually be removed.

Support

This ZenPack is developed by the Zenoss user community and supported via our online forums. Zenoss, Inc. does not provide direct support for this ZenPack.

Releases

Version 3.0- Download
Summary of changes: Updated for Zenoss 4.2
Released on 2012/11/01
Compatible with Zenoss Core 4.2.x
Version 2.1- Download
Released on 2012/11/01
Compatible with Zenoss Core 3.1.x, Zenoss Core 3.2.x

Background

This ZenPack adds a new Predictive Threshold type for determining when to trigger an event. The threshold uses the Holt-Winters Forecasting from RRDTool.

Installation

Normal Installation (packaged egg)

  1. Download the appropriate egg file for the version of Zenoss you are running.
  2. Ensure you are logged in as the zenoss user:
    $ sudo su - zenoss
  3. Install the ZenPack:
    $ zenpack --install ZenPacks.community.PredictiveThreshold-*.egg
  4. Restart these services:
    $ zenoss restart

Developer Mode Installation

In order to do a development mode installation you will want to clone the existing git repository, and then use the --link flag with the zenpack command:

  1. Ensure you are logged in as the zenoss user:
    $ sudo su - zenoss
  2. Start by cloning the upstream repository:
    $ git clone https://github.com/jcurry/ZenPacks.community.PredictiveThreshold
  3. Next, perform the installation:
    $ zenpack --link --install ZenPacks.community.PredictiveThreshold
  4. Finally, restart these serivices:
    $ zenoss restart

Discuss

Purplemarker.png New: Don't forget to add yourself to the Zenoss User Map!

blog comments powered by Disqus