Zenoss Core 4.2.0 SP1

From Zenoss Wiki
Revision as of 16:21, 21 November 2013 by Crouthamela (Talk | contribs)$7

(diff) ← Older revision | Approved revision (diff) | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search

Zenoss Core 4.2.0 SP1 is a community-maintained service pack for Zenoss Core 4.2.0 that fixes the following bugs:

These fixes will result in an improved user interface experience and improved performance.

Optional Fixes

Fixes for the following issues will be applied if PySamba is installed. PySamba is part of the Core ZenPacks for Zenoss Core 4, and will be installed if you used the auto-deploy script:

  • ZEN-3193 - PySamba - memory leak
  • ZEN-3194 - PySamba - fix WBEM qualifiers processing

Credits

Thanks to Ryan Matte for his extensive testing and troubleshooting work, which made this Service Pack possible. Many thanks to Egor Puzanov for tracking down the PySamba memory leak and qualifiers processing bug. Thanks to Zenoss Developers Tim Sanders, Evan Powell, Joseph Hanson and Jason Peacock for testing, patches, and more testing.

To Apply (BETA)

As root, install prerequisites. Note that you will need to have the EPEL repo enabled for git to install properly. EPEL will be configured but not enabled by default after you use the auto-deploy script:

# yum --enablerepo=epel install git
# yum install patch
# yum install unzip

As the zenoss user, download and run the service pack:

$ cd /var/tmp
$ git clone git://github.com/zenoss/CoreServicePacks.git
$ cd CoreServicePacks/4.2.0-SP1
$ ./apply.sh
$ zenoss restart

If you are behind an HTTP proxy and firewall, you may need to use the following approach to grab the CoreServicePacks git repository, rather than the git clone command above:

$ git config --global http.proxy proxyname:port
$ git clone --verbose --progress http://github.com/zenoss/CoreServicePacks.git

Patched Versions of Zenoss

If you already have your own fixes applied to Zenoss, then the Service Pack may fail to apply properly. If you are a power-user, you can follow these steps to apply the patches manually. These steps are essentially what the apply.sh script does, but our script expects all patches to apply perfectly, and also provides a roll-back mechanism by backing up all modified files. Manual steps:

  • Use patch -p3 in $ZENHOME to apply all the patches in the 4.2.0-SP1/patches directory manually. If a patch fails, you can look at the .rej file and manually resolve rejected parts of the patch.
  • run 4.2.0-SP1/scripts/buildjs.sh as the zenoss user to rebuild the compiled JavaScript files.

Purplemarker.png New: Don't forget to add yourself to the Zenoss User Map!

blog comments powered by Disqus